nixos/configuration.nix
2024-09-20 18:00:01 +02:00

249 lines
6 KiB
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

# Edit this configuration file to define what should be installed on
# your system. Help is available in the configuration.nix(5) man page
# and in the NixOS manual (accessible by running nixos-help).
{ config, pkgs, ... }:
{
imports =
[ # Include the results of the hardware scan.
./hardware-configuration.nix
];
# Bootloader.
boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = true;
networking = {
hostName = "ocean-princess"; # Define your hostname.
networkmanager.enable = true;
};
# Set your time zone.
time.timeZone = "Europe/Copenhagen";
# Select internationalisation properties.
i18n = {
defaultLocale = "en_DK.UTF-8";
extraLocaleSettings = {
LC_ADDRESS = "en_DK.UTF-8";
LC_IDENTIFICATION = "en_DK.UTF-8";
LC_MEASUREMENT = "en_DK.UTF-8";
LC_MONETARY = "en_DK.UTF-8";
LC_NAME = "en_DK.UTF-8";
LC_NUMERIC = "en_DK.UTF-8";
LC_PAPER = "en_DK.UTF-8";
LC_TELEPHONE = "en_DK.UTF-8";
LC_TIME = "en_DK.UTF-8";
};
};
# Enable the X11 windowing system.
services.xserver = {
enable = true;
excludePackages = [ pkgs.xterm ];
xkb = {
layout = "dk";
variant = "";
};
};
# Enable the KDE Plasma Desktop Environment.
services.displayManager.sddm.enable = true;
services.desktopManager.plasma6.enable = true;
programs.kdeconnect.enable = true;
# Configure console keymap
console.keyMap = "dk-latin1";
fonts = {
enableDefaultPackages = true;
packages = with pkgs; [
noto-fonts
noto-fonts-emoji
noto-fonts-cjk
liberation_ttf
nerdfonts
source-code-pro
];
};
# Enable CUPS to print documents.
services.printing.enable = true;
services.avahi = {
enable = true;
nssmdns4 = true;
};
# Enable sound with pipewire.
sound.enable = false;
hardware.pulseaudio.enable = false;
security.rtkit.enable = true;
services.pipewire = {
enable = true;
alsa.enable = true;
alsa.support32Bit = true;
pulse.enable = true;
# If you want to use JACK applications, uncomment this
jack.enable = true;
};
hardware.bluetooth.enable = true;
hardware.opengl = {
enable = true;
driSupport = true;
driSupport32Bit = true;
};
# Enable touchpad support (enabled default in most desktopManager).
# services.xserver.libinput.enable = true;
# Define a user account. Don't forget to set a password with passwd.
users.users.ed = {
isNormalUser = true;
description = "Ed";
extraGroups = [ "networkmanager" "wheel" "transmission" ];
shell = pkgs.zsh;
#packages = with pkgs; [
# firefox-esr
# thunderbird
#];
};
programs.appimage = {
enable = true;
binfmt = true;
};
programs.steam.enable = true;
programs.zsh.enable = true;
environment.pathsToLink = [ "/share/zsh" ]; # for zsh completion
services.transmission = {
enable = false;
package = pkgs.transmission_4;
group = "users";
settings = {
download-dir = "/home/ed/Downloads";
ratio-limit = 1;
ratio-limit-enabled = true;
idle-seeding-limit-enabled = true;
};
};
services.locate = { #emacs
enable = true;
interval = "hourly";
package = pkgs.plocate;
localuser = null;
};
# Allow unfree packages
nixpkgs.config.allowUnfree = true;
# List packages installed in system profile. To search, run:
# $ nix search wget
environment.systemPackages = with pkgs; [
neovim # Do not forget to add an editor to edit configuration.nix! The Nano editor is also installed by default.
git
(lutris.override {
extraLibraries = pkgs: [
gdk-pixbuf
# libgobject-2.0.so.0
# libglib-2.0.so.0
# libgio-2.0.so.0
glib
# libnss3.so
# libnssutil3.so
# libsmime3.so
nss
# libnspr4.so
nspr
# libatk-1.0.so.0
# libatk-bridge-2.0.so.0
# libatspi.so.0
at-spi2-core
# libcups.so.2
cups
# libdrm.so.2
libdrm
# libdbus-1.so.3
dbus
# libX11.so.6
xorg.libX11
# libXcomposite.so.1
xorg.libXcomposite
# libXdamage.so.1
xorg.libXdamage
# libXext.so.6
xorg.libXext
# libXfixes.so.3
xorg.libXfixes
# libXrandr.so.2
xorg.libXrandr
# libgbm.so.1
mesa
# libexpat.so.1
expat
# libxcb.so.1
xorg.libxcb
# libxkbcommon.so.0
libxkbcommon
# libpango-1.0.so.0
pango
# libcairo.so.2
cairo
# libasound.so.2
alsa-lib
];
extraPkgs = pkgs: [
appimage-run
];
})
wineWowPackages.stable
unar #ark
p7zip #ark
kmymoney
digikam
exiftool # for digikam
okteta
kdePackages.kcalc
kdePackages.partitionmanager
kdePackages.filelight
kdePackages.korganizer
pkgsi686Linux.gperftools
wget
];
# Some programs need SUID wrappers, can be configured further or are
# started in user sessions.
# programs.mtr.enable = true;
# programs.gnupg.agent = {
# enable = true;
# enableSSHSupport = true;
# };
# List services that you want to enable:
# Enable the OpenSSH daemon.
# services.openssh.enable = true;
# Open ports in the firewall.
networking.firewall.allowedTCPPorts = [ 6680 ];
# networking.firewall.allowedUDPPorts = [ ... ];
# Or disable the firewall altogether.
# networking.firewall.enable = false;
nix.settings.experimental-features = [ "nix-command" "flakes" ];
# This value determines the NixOS release from which the default
# settings for stateful data, like file locations and database versions
# on your system were taken. Its perfectly fine and recommended to leave
# this value at the release version of the first install of this system.
# Before changing this value read the documentation for this option
# (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
system.stateVersion = "23.11"; # Did you read the comment?
}